Linode 的 VPS ,比较早了,所以是Debian 7.4,今天要升级一个程序,一直报错,apt-get update 也报错

类似这种错误
# The following packages have unmet dependencies
# W: Ignoring Provides line with DepCompareOp for package

我估计是安装包和依赖包的版本跟目前的Debian版本不符合,或是不支持目前的版本。

比较简单的方法就是升级Debian,网上查了下,貌似Debian不能直接7升级到9,先到Debian 8。

我是参考的这2个文章,
https://blog.csdn.net/appleyuchi/article/details/79349858
https://blog.csdn.net/rainysia/article/details/45306717 ,感谢下。

升级源我没有用 163.com 的,升级过程中PuTTY网络中断了,掉线了,重新SSH,哈哈接不上了,怎么办。等一会,重新 # apt-get dist-upgrade ,报错 Could not get lock /var/lib/apt/lists/lock,根据这个文章 https://blog.csdn.net/xu380393916/article/details/53665041 排错。

重新 # apt-get dist-upgrade ,然后 # lsb_release -a , OK 升级成功。

然后再安装软件就不报错了。

Debian9就暂时不升级了。

说一下Debian,我最早在2004的时候就接触过Debian,后来转到了FreeBSD。后来用VPS的时候,FreeBSD的很少,就又用起了Debian。Debian很不错的,也是稳稳的。

0 Comments

Leave a Reply

Your email address will not be published. Required fields are marked *